No Authentication Schemes Configured

Hi,

I've been using RealVNC for a long time but in the past few months my Home subscription has not worked because now I get an error on my Linux Mint machine:
"VNC Server has no authentication schemes configured. Please check VNC Server configuration and try again."

Then when I try to access the Options tab, I get stuck with an error:

"Unable to configure options for VNC Server.

This requires superuser access when running in service mode as the
changes will affect all users of this system. Either you do not have a
suitable method configured to gain superuser privileges (e.g. sudo),
you are not authorised to do this, or you supplied invalid credentials."

In order to force my License setup, I just ran sudo vnclicensewiz or use this quick trick:

https://help.realvnc.com/hc/en-us/community/posts/5021325365917-VNC-Server-wont-work-on-a-new-Ubuntu-Desktop-Install

I'm stuck now though. I either need to know which program runs the "Options" so I can run it in sudo, or fix it some other way.

Thank you!

TD

1

Comments

3 comments
  • I ran into same problem, got it fixed with:

    running `sudo vncpasswd -service` then typing the password you will use for connection to the vnc server

    editing `/root/.vnc/config.d/vncserver-x11` file as root

    adding `Authentication=VncAuth` to the end of the file

    restarting vncserver service - `sudo systemctl restart vncserver-x11-serviced.service`

    here is the reference for what i used:

    https://help.realvnc.com/hc/en-us/articles/360002253878-Configuring-VNC-Connect-Using-Parameters#populating-vnc-configuration-files-with-parameters-0-2 

    https://help.realvnc.com/hc/en-us/articles/360002251297-VNC-Server-Parameter-Reference-#Authentication

    the program for option settings (vncserverui) cannot be run directly from terminal but you can adjust every possible option manually with the help of the above links

    2
    Comment actions Permalink
  • that worked perfectly. Thanks!!

    the key was 'sudo vncpasswd -service' because it needed to be encrypted in the config file.

    0
    Comment actions Permalink
  • Thanks very much Jenny!

     

    My RealVNC subscription: home

    My OS: Antix 21, initd, (bullseye)

    I struggled for about 3 days before stumbling on this at 2 am.

    I knew it had to do with permissions but could not solve by executing as root.

    My errors I were getting in the Real VNC server (1st  VNC-Server-6.10.0-Linux-x64.deb and 2nd  VNC-Server-6.10.0-Linux-x64-ANY.tar.gz) gui were:

    VNC server security settings not configured
    Authentication scheme not supported

    I ran: sudo vnclicensewiz

    but still ended up with .....This requires superuser access........when trying to resolve through gui.

     

    Strangely I installed the exact same server file in antix 19.1 and it ran without a hitch.

    MX Linux 19.2 and later also run without problems.

    After following your steps..........

     

     

    0
    Comment actions Permalink

Please sign in to leave a comment.

Didn't find what you were looking for?

New post