Adding a new VNCserver fails

When I run the vncsetup.sh script on a new computer - and use option 1, 4 to sign in to my VNC account - I get a certificate expiry error.

VendorConfig: Error in Certificate "CN=GlobalSign,O=GlobalSign,OU=GlobalSign Root CA - R2": X.509 Error: Certificate expired

The computer gets added to my VNC account - but VNCserver won't start.

If I start again, the computer gets added again......

0

Comments

6 comments
  • Hi Derek,

    Thanks for your post. Regarding the error, please see my response on your other thread here: https://help.realvnc.com/hc/en-us/community/posts/4404911507101-Adding-a-new-VNCserver-fails

    Regarding VNC Server not starting, do you see any other messages other than the certificate expiry? After licensing with option 1 and then 4, have you used option 2 to start the Service Mode daemon?

     

    0
    Comment actions Permalink
  • Yes - I started the service daemon and then go through the steps to enable at boot and now.

    I then try to use 1, 4 and I get an error message after entering the authenticator code and local password.

    X Unable to obtain the current configuration

    At no point do I see the VNCserver information page.

    I do get multiple entries in VNC Connect - so I now have System and System (2) and both of them show the outline of a screen - rather than a screenview of the last screen used.

    I'd guess that there is something incomplete because of the failed certificate.

    I can't delete the entries in VNC Connect - but can delete them if I go the manage my account web-page.

    0
    Comment actions Permalink
  • Hi Derek,

    Does the service show as running or report any errors (other than the expired certificate, which can be safely ignored)? You can check with: sudo systemctl status vncserver-x11-serviced

    What error do you see when trying to connect to the VNC Server from VNC Viewer - it should be listed under your Team since it appears in the portal. Make sure you connect to the one with the highest number e.g. (2) as previous entries will no longer work.

    Re. removing computers - currently they can only be removed via the portal and not from the Viewer software, as you've spotted already.

    Re. the outline - this is the default icon for a new connection, the screenshot is only updated after a successful connection from VNC Viewer.

    Can I also check which OS and version of VNC Server you downloaded please?

    Thanks,

    Jack N

    0
    Comment actions Permalink
  • Still baffled - three answers below - thanks for the suggestions -

    1) sudo systemctl status vncserver-x11-serviced output -

    vncserver-x11-serviced.service - VNC Server in Service Mode daemon
    Loaded: loaded (/lib/systemd/system/vncserver-x11-serviced.service; enabled
    ; vendor preset: enabled)
    Active: active (running) since Fri 2022-02-11 10:20:47 GMT; 13min ago
    Main PID: 4091 (vncserver-x11-s)
    Tasks: 2 (limit: 8782)
    Memory: 2.2M
    CPU: 31ms
    CGroup: /system.slice/vncserver-x11-serviced.service
    ├─4091 /usr/bin/vncserver-x11-serviced -fg
    └─4092 /usr/bin/vncserver-x11-core -service

    Feb 11 10:20:47 derek-Z585 systemd[1]: Started VNC Server in Service Mode daemon
    .
    Feb 11 10:20:47 derek-Z585 vncserver-x11[4092]: LogDestMem: Start replaying stor
    ed messages
    Feb 11 10:20:47 derek-Z585 vncserver-x11[4092]: VendorConfig: Error in Certifica
    te "CN=GlobalSign,O=GlobalSign,OU=GlobalSign Root CA - R2": X.509 Error: Certifi
    cate expired
    Feb 11 10:20:47 derek-Z585 vncserver-x11[4092]: LogDestMem: Finished replaying s
    tored messages
    Feb 11 10:20:47 derek-Z585 vncserver-x11[4092]: ServerManager: Server started

    2) Error from VNC Viewer

    VNC Server is not currently listening for Cloud connections


    3) OS etc

    Extracts from sudo vnclicense
    VNC Server Licensing 6.8.0 (r45849) x64 (Oct 14 2021 14:48:48)
    OS: Ubuntu 21.10, Linux 5.13.0, amd64

    0
    Comment actions Permalink
  • Hi Derek,

    Thanks for your reply. The setup script should have handled this, but can you check if WaylandEnabled = false is still commented out in /etc/gdm3/custom.conf please?

    0
    Comment actions Permalink
  • Yes it is commented out - thanks.

    Problem is now resolved - mea culpa.

    Your post reminded me that I need to be using Xorg - when I login, there are 2 option

    Ubuntu

    Ubuntu on Xorg

    with the default being Ubuntu.

    Switch the option and it all works fine.

    0
    Comment actions Permalink

Please sign in to leave a comment.

Didn't find what you were looking for?

New post