VNC Server has no authentication schemes configured.

Hi,

I installed VNC Server on Windows 10 but it doesn't start and there is no icon in the taskbar. When I try to connect remotely the following error message pops up.

VNC Server has no authentication schemes configured.

Please help.

0

Comments

8 comments
  • Official comment

    Hi,

    Thanks for confirming. I've done some testing internally and been able to reproduce the issue. This looks like it might be a bug in the License Wizard specifically when applying a Home subscription using the License Wizard over RDP. I've raised this with our development team, thank you for reporting this!

    To resolve the issue, you'll need to visit the VNC Server computer and open the Options menu via the tray icon, and manually set Authentication to VNC Password, and set a VNC Password when prompted after clicking Apply.

    Alternatively, to fix it at the command line, run the below commands in an elevated Powershell window. The second command will prompt you to enter and confirm the password you would like to use with VNC Server. After its completed, you should be able to connect from VNC Viewer.

    New-ItemProperty -Path "HKLM:\Software\RealVNC\vncserver" -Name "Authentication" -Value "VncAuth"
    & "C:\Program Files\RealVNC\VNC Server\vncpasswd.exe" -service

    Thanks,

    Jack

    Comment actions Permalink
  • Hi,

    Thanks for your post. Did you install VNC Server over RDP, or if it is a virtual machine, through Hyper-V manager? Can I also check if you installed VNC Server 6.11.0 and if you were trying to use a Home subscription with VNC Server?

    Thanks,

    Jack

    0
    Comment actions Permalink
  • Thank you Jack for your reply. Yes, I did install the VNC Server over RDP but on a physical machine. Installed VNC Server is 6.11.0 using Home subscription.

    0
    Comment actions Permalink
  • Hi There,

    I have the same problem! I cannot logon to the physical machine because its a virtual server.

    I typed your line in the terminal and get some sort of an error message. However, I am able to set the password and it still did not work.


    After that I tried to set the thing in the registry manually. 

     

    But still does not work

    Will there be an update in future so that I am able to use your software again?

     

     

    0
    Comment actions Permalink
  • Hi Sebastian,

    Thanks for your post. The commands provided need to be run in Powershell, rather than Command Prompt. Can you try running them there and let me know if it helps?

    For your manual Registry edit, it looks like you may have added the value to the RealVNC key, rather than the vncserver key underneath it. Can you please double check? Note, you will need to restart VNC Server after manually editing the Registry.

    Thanks,

    Jack

     

     

    0
    Comment actions Permalink
  • Ah cool, thank you , I am trying it!

    And is „VncAuth“ the correct value or is it just a placeholder for my user name / email address?
     
    Best regards
    Sebastian
    0
    Comment actions Permalink
  • Hi Sebastian,

    VncAuth is the correct value to use!

    Thanks,

    Jack

    0
    Comment actions Permalink
  • Hi Jack,

    yeah, it worked now! I gave up on that already.

    Thanks a ton!! :)

     

    Best regards

    Sebastian

     

    0
    Comment actions Permalink

Please sign in to leave a comment.

Didn't find what you were looking for?

New post