Hide banner dialog

Hi, on Ubuntu 20.04, I'm running `vncviewer -listen` and I'm waiting for reverse connections that arrive with `x11vnc -connect my-ip`.

Every time a connection arrives, a small dialog with the VNC banner/logo appears for a second, then the remote screen window is shown.

Is there a configuration option that will allow me to hide that banner dialog?

While usually it's not very annoying, my computer has a public IP, and when bots happen to scan my 5500 port where vncviewer is listening on, that banner appears all the time even if it's just a port scan and not a real connection, and this interrupts my work too frequently.

Thank you for your great product!

1

Comments

2 comments
  • Unfortunately the banner causes a second, more important issue.

    If we try to show the "teacher screen" to a "student pc" that is at the lightdm login screen, it is shown correctly for a second, but then when the banner goes away, the VNC window gets hidden behind lightdm (there's no window manager running at that point).

    Is there really no way to disable the banner dialog, since it's causing so many issues?

    1
    Comment actions Permalink
  • Hi, is there any way to get feedback from the development team, if they're planning to fix this issue, especially the second part/post?

    We can't buy/use RealVNC until this issue is fixed...

    0
    Comment actions Permalink

Please sign in to leave a comment.

Didn't find what you were looking for?

New post