I port forwarded, but why is port still closed?

Hello, please help me port forward VNC 5900 for remote viewing.
I'm running vm router OPNsense 23.1.11_1-amd64
FreeBSD 13.1-RELEASE-p8
OpenSSL 1.1.1u 30 May 2023

These are the steps I processed:
Ubuntu 22.04.3 LTS jammy > Sharing is turned on.

VMM 4.0.0 is running VM OPNsense port forwarded to 5900.

I tested the port is forwarded, GRC Shields UP shows 5900 is open by the VNC system.

I also tested from my phone's RealVNC app with publicWanIP and publicWanIP:5900, but error: The connection attempt timed out.



  • Here's the port forward details:

    • Interface: WAN, Proto: TCP, Address: *, Ports: *, Address: WAN address, Ports: 5900 (VNC), IP:, Ports: 5900 (VNC), Description: VNC 5900.

    Whilst attempting to remotely connect from my phone's RealVNC app,
    I ran OPNsense's Packet Capture on Interfaces WAN and LAN for port 5900 and no traffic.

    I ran OPNsense's Packet Capture on Interfaces WAN and LAN for all ports and traffic.

    I ran Ubuntu's GUFW and the report shows:
    No 3;
    Protocol TCP6;
    Port 5900;
    Address *;
    Application gnome-remote-desktop-daemon.

    Not sure why packets from phone aren't shown on OPNsense or Ubuntu's traffic analysis?

    Comment actions Permalink
  • This is my home network topology:

    Comment actions Permalink

Please sign in to leave a comment.

Didn't find what you were looking for?

New post