Why do I see "RealVNC Viewer must be updated to use RealVNC services." when trying to connect to a remote device?

Follow

If you see an error message stating "RealVNC Viewer must be updated to use RealVNC services." (as shown below) when trying to connect to a remote device, this is because you are trying to connect to a RealVNC Server linked to a Home subscription/team, which has now been retired.

Please see this page for more information: RealVNC Connect Home Subscriptions - Important Information



If you already have a paid, trial or Lite subscription, to restore connectivity, you will need to move your device(s) to your paid team.

To do this, you need to re-run the License Wizard on your remote device(s) as shown here: How do I re-join a RealVNC Server to the cloud, or change which team RealVNC Server belongs to?

Looking for the latest version's features and download links?

Please visit our Release Notes page here for download links as well as a list of the new features, improvements and features in RealVNC Connect

Was this article helpful?
0 out of 6 found this helpful

Comments

0 comments

Article is closed for comments.